Recent Activity

Activity stream for all registered members at Hyundai Forums.

  1. avisitor replied to the thread 13 Santa Fe starting.

    You don't have a brake lamp issue. Your dash goes out completely. Like there is no power. I would suspect the push button start control...

    Dec 9, 2019 at 4:19 AM
  2. jetautomech replied to the thread 13 Santa Fe starting.

    Checked fuses, relays, replaced neutral safety switch, tried starting like the owner manuals stated for brake stop lamp fuses blown.

    Dec 8, 2019 at 7:57 AM
  3. avisitor replied to the thread 13 Santa Fe starting.

    Personally don't have enough experience working with push button start systems. Do you wish to troubleshoot this yourself or are you...

    Dec 8, 2019 at 4:52 AM
  4. jetautomech posted a new thread.

    13 Santa Fe starting

    My 2013 Santa Fe sport 2.0t will not start. When the start button is pressed, the radio, temperature control lights go off and after...

    Forum: Hyundai Santa Fe

    Dec 8, 2019 at 2:45 AM
  5. GEZ replied to the thread Deep resonance between 1000 - 2000 rpm.

    I have a 2001 XG300 with 85000. I'm the original owner. Had a similar issue years back. It felt like a "shudder" of aprox. 1-2 seconds....

    Dec 7, 2019 at 2:15 PM
  6. milehi replied to the thread Deep resonance between 1000 - 2000 rpm.

    No, but I will be removing belts to check if to see if any of the parasites (PS,Alt, Ac) ect are playing a role. Got to wait for warmer...

    Dec 7, 2019 at 3:37 AM
  7. TurboRev replied to the thread Bumper Cover 2013 Elantra.

    Enter your VIN on https://www.hyundaipartsdeal.com/ . The website will then notify you if your vehicle is Korean or USA assembled so...

    Dec 6, 2019 at 4:28 PM
  8. TurboRev replied to the thread 2013 Santa Fe Sport.

    Check your owner's manual

    Dec 6, 2019 at 4:22 PM
  9. GEZ replied to the thread Deep resonance between 1000 - 2000 rpm.

    Milehi Does your problem occur during gear shifts?

    Dec 5, 2019 at 5:56 PM
  10. GEZ replied to the thread Hard shift on 2016 santa fe sport.

    I have a 2001 XG300 5-speed autotrans with similar problems. P072 code. Shaft output speed sensor. If you have no codes may God help you...

    Dec 5, 2019 at 2:02 PM
  11. GEZ posted a new thread.

    Transmission shifting erractic

    2001 XG300 5-speed autotrans has erratic up and downshifting issues. Works fine until well warmed up. suspect the shaft output speed...

    Forum: Other Honda Models

    Dec 5, 2019 at 1:39 PM
Loading...