2001 Hyundai Accent. Blows cold air :(

Discussion in 'Hyundai Accent' started by lancefthib1, Jan 16, 2012.

  1. lancefthib1

    lancefthib1

    Joined:
    Jan 16, 2012
    Messages:
    1
    Likes Received:
    0
    The heat worked awesome in this car for the first few months of ownership. On an icey day I drove it over a sidewalk & into a parking lot :( I stopped as soon has I parked to check & make sure I didn't knock the oil pan or anything off. Everything seemed OK. No loose wires, no dripping, not even a dent (hit left corner of the cars frame). The thing is, soon as I started driving... the heat becomes less powerful.. not the power of the air... but the heat itself... it goes on for about another week then the heat just stops working. I replaced the thermostat & changed the coolant to see if it would change anything... it did absolutely nothing...The heat level occasionally will rise over the middle mark on the gauge.. but nothing else... I'm so dumbfounded on what could be the issue. Maybe a new heater core? is there a line that may have ripped off while flying over the iced barrier/sidewalk?

    Any ideas or information would help.. It -40 where I'm at! (heat worked in -40 before accident just fine)

    Radiator was not hit in anyway, still works fine

    Also, I already had issues with the wire leading to the heater flap (messed it up while trying to put new deck in). I had the flap manually turned all the way to the heat side.. Now it doesn't make a difference what side I have the flap turned.. Just cold all the time
     
    lancefthib1, Jan 16, 2012
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.