2005 accent transmission

Discussion in 'Hyundai Accent' started by Bob Baker, Nov 11, 2017.

  1. Bob Baker

    Bob Baker

    Joined:
    Nov 11, 2017
    Messages:
    2
    Likes Received:
    0
    Check engine light came on. code 713 (transmission fluid temp sensor). Replaced. Would not shift into overdrive. After 50 miles shifted into overdrive. Light came on (code 713). Dealer said it must be TCM (transmission control module) giving false signal to ECM (engine control module) to turn on light. This model has TCM and ECM in same unit. Replaced. Would not shift into overdrive. After 50 miles shifted into overdrive. Light came on (code 713). Transmission works perfectly when light is on. Smooth clean shifts with no slipping. Any suggestions?
     
    Bob Baker, Nov 11, 2017
    #1
    1. Advertisements

  2. Bob Baker

    avisitor

    Joined:
    Jul 30, 2017
    Messages:
    311
    Likes Received:
    13
    Location:
    Albany, NY
    Yeah, tell the dealer to give you your money back for replacing the wrong part.
    If you replaced the TC sensor ad the TCM
    then all that is left is the associated wiring and/or the transmission
    I tend to go for the wiring. It can be quite challenging to find the real issue

    I wish you luck
     
    avisitor, Nov 12, 2017
    #2
    1. Advertisements

  3. Bob Baker

    Bob Baker

    Joined:
    Nov 11, 2017
    Messages:
    2
    Likes Received:
    0
    Thank you avisitor. I have a mechanic that can start checking the wiring today. Maybe he'll get lucky.
     
    Bob Baker, Nov 13, 2017
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.