2011 Tucson Rear Camera - broke

Discussion in 'Forum Feedback / Announcements' started by Ric, Mar 5, 2019.

  1. Ric

    Ric

    Joined:
    Mar 5, 2019
    Messages:
    3
    Likes Received:
    0
    On my 2011 Tucson - rear camera just went blank - not working - Brought it to the Dealer in Elgin IL. they want $515.00 plus tax to put a new one in..... has this happened to anyone else? Seems to me that this should not be breaking - My Toyota RAV 4 with 140 thousands miles on it has no issue with the rear camera / I tried to do the reset that is for the radio - no luck - I slammed the trunk about 5 times - still not working ---
     
    Ric, Mar 5, 2019
    #1
    1. Advertisements

  2. Ric

    avisitor

    Joined:
    Jul 30, 2017
    Messages:
    342
    Likes Received:
    14
    Location:
    Albany, NY
    Could it be the fuse?
    Or may be the wiring where the rear door hinges upon?
    See if the unit at the rear is receiving power
     
    avisitor, Mar 8, 2019
    #2
    1. Advertisements

  3. Ric

    Ric

    Joined:
    Mar 5, 2019
    Messages:
    3
    Likes Received:
    0
    Gee it may be a fuse??? how would I know which one?
     
    Ric, Mar 9, 2019
    #3
  4. Ric

    avisitor

    Joined:
    Jul 30, 2017
    Messages:
    342
    Likes Received:
    14
    Location:
    Albany, NY
    Rear camera is usually powered by the reverse lights.
    Putting the transmission into reverse turns on the reverse lights and also the camera.
    Check to see if you have the reverse lights.
     
    avisitor, Mar 11, 2019
    #4
  5. Ric

    Ric

    Joined:
    Mar 5, 2019
    Messages:
    3
    Likes Received:
    0
    I checked the reverse lights .... THE REAR LIGHTS WORKED - HOWEVER THE TAIL LIGHT WAS OUT ...WHICH I FIXED - A VERY EASY FIX.... $7.00 FOR 2 NEW LIGHT BULBS ...
    I AM GOING TO CHECK FOR THE FUSE NEXT NOW...
     
    Ric, Mar 12, 2019
    #5
  6. Ric

    avisitor

    Joined:
    Jul 30, 2017
    Messages:
    342
    Likes Received:
    14
    Location:
    Albany, NY
    No need to check the fuse. Usually, the reverse and rear camera are on the same circuit.
    Am suspecting a broken wire or a broken camera.
    You may need to inspect the camera to see if it working.

    Good luck to you
     
    avisitor, Mar 13, 2019
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.