Hyundia Tucson CRTD GSI 1991cc 2005

Discussion in 'Hyundai Tucson' started by schubi1962, Oct 20, 2017.

  1. schubi1962

    schubi1962

    Joined:
    Oct 20, 2017
    Messages:
    1
    Likes Received:
    0
    Hi, All

    Having pulsing at the brake peddle but it also goes stiff then releases if hard break pressure is applied.

    This happens at at slow speed. but is intermittent.

    The ABS and TCS lights come on at 60 to 70 mph, once I have done 5 to 10 miles on the motorway. But once the engine is turned off the system resets and the lights do not come on again until I go on back on the motorway travelling 60 to 70 mph as above. There is no error left in the ecu when a computer is plugged in, so my local garage cannot pinpoint the error.

    I have changed the G sensor when this issue first started as it come up as an error on the computer this has not fixed the problem.

    I have also changed the brake discs front and back and brake shoes.

    The AWD light also comes on (flashing) at 70mph after 5 to 10 miles but also resets once the engine is turned off.

    Anyone had this problem and can advise me what to do.

    Thanks Nick
     
    Last edited: Oct 20, 2017
    schubi1962, Oct 20, 2017
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.