loud humming sound at low speeds after highway driving?

Discussion in 'Hyundai Santa Fe' started by fiddlerdog, Aug 29, 2014.

  1. fiddlerdog

    fiddlerdog

    Joined:
    Aug 29, 2014
    Messages:
    1
    Likes Received:
    0
    I have a 2004 Santa Fe with 130,000 miles on it. This summer I drove it from Cali to Texas and back. No problems there but on the way back after hours of highway driving (avg 80mph) when I would take it off the highway the car would make a lot of noise, humming perhaps, at low speeds.

    The sound doesn't get worse with turning and does not occur at idling. The sound occurs with acceleration, like it is working way too hard to accelerate to such low speeds. Additionally, once I take my foot off the pedal it doesn't immediately stop but takes several seconds seemingly proportionate to the decrease in speed. Additionally, after parking it for a few hours, it doesn't make the sound anymore. What is going on? Can I have some advice here? Transmission, engine?

    Thanks
     
    fiddlerdog, Aug 29, 2014
    #1
    1. Advertisements

  2. fiddlerdog

    Antoinette Black

    Joined:
    Mar 5, 2015
    Messages:
    1
    Likes Received:
    0
    Have driveshaft carrier bearing checked. I have 105000 miles on my AWD and it developed a humming sound when braking and low speeds. Getting bearing replaced Monday at dealer...
     
    Antoinette Black, Mar 5, 2015
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.